[xstreamos-discuss] beta3 on an old iMac

Marion Hakanson hakansom at ohsu.edu
Sun Dec 7 00:19:51 CET 2014


Thanks for all your work on XStreamOS Desktop.  I'm trying it out as a
potential replacement for my stale/stagnant oi151a7 and oi151a9 desktops.

Today, I tried to install it on an old 2006 Intel iMac, which platform has
been used successfully for OpenIndiana by others.  People report that you
just format/partition the internal drive as an MBR disk, then boot up the
install DVD, and away you go.

In my first attempts, the text installer got to the point where it displays
the installation progress bar, but progress stops at about 1%.  After
a little while the DVD drive stops spinning, and eventually (about 15
minutes total), the install script says installation has failed.  Viewing
the installation log shows only:

2014-12-06 12:38:33,934 - INFO    : text-install:120 **** START ****
2014-12-06 12:39:22,780 - INFO    : network_type.py:181 Configuring NIC as: 
2014-12-06 04:52:19,430 - ERROR   : ti_install.py:359 Failed to transfer bits 
to the target

While trying to debug, I discovered that the "Shell" mode of the install menu
doesn't work;  When attempting to start "Shell" mode, sometimes I could see
this error flash by on the screen:

/usr/bin/bash: /usr/bin/bash: Cannot execute: [Exec format error]

This turned out to be a bit of a clue, I think.  I know that this old iMac
has a 64-bit CPU, but its bootloader is 32-bit.  So I tried editing the
GRUB entry, replacing all occurrences of "$ISADIR" with "amd64".  After
doing so, the "Shell" mode actually works, and the text installer actually
succeeds.  I had to edit /rpool/boot/grub/menu.lst after installation, so
subsequent boots would work, as well.

I haven't had a chance to try everything out yet, but I've noticed there
is no driver for the iMac's onboard wifi (BCM4321), which I've read will
require installing an ndis wrapper.  But gigabit ethernet works OK.



More information about the XStreamOS-discuss mailing list